STK500 error when flashing Marlin

Step by step help for new users installing Marlin for the first time
Post Reply
zero2005
Posts: 2
Joined: Sun Mar 11, 2018 3:23 am

STK500 error when flashing Marlin

Post: # 741Post zero2005
Sun Mar 11, 2018 3:35 am

So, i've followed all the guides out there and tried several things. I'm trying to get Marlin so I can properly use my Auto bed level sensor.

First, it should be noted I have an anet A8 "-L" which is the factory included auto bed level sensor and custom A8-L firmware with auto bed leveling. the mainboard is "v1-5" with the newer spade connectors for the heaters. the A8-L firmware seems kinda crap as when I tried to include the G29 code it just ignores it, and the custom bed level function in the menu's seems hoaky at best -- as if it just moves the Z-limit switch from a mechanical switch to a hall effect switch on the print head and little else..

I've tried 2 different laptops (though both with Windows 10), using both the Arduino IDE and the Marlin Configurator.

Error i'm getting is:
AVRDUDE STK500_GETSYNC(): NOT IN SYNC RESP

it repeats this 10 times than fails out.
I can send manual commands, and the machine responds, via the marlin configurator.
I have a USBASP on order, should be here tomorrow -- to hopefully flash the optiboot bootloader. but I feel like that should be my last resort?

list of things i've tried so far:
unplugging almost everything other than the 12v power in and USB and attempt to flash
using 2 different laptops (though both with windows 10)
changing drivers from the CH341 driver to libusb and a few others (using Zadig)
using the arduino IDE as well as the marlin configurator.
verifying that the proper com port and board selected (anet 1.0) are correct.
using a different USB cable (original blue one is dead, does not work)

Just tried pulling the board off and put ~11v to it, powers up, also getting error with my desktop.
also tried using AVRDUDESS v2.4 to try and flash the stock Anet firmwares (both A8 and A8L)
tried downgrading to arduino 1.6.3, cannot even compile, back to 1.8.5.


anyone else had this problem? other ways to fix this? or am I basically out of luck until I flash Optiboot?



zero2005
Posts: 2
Joined: Sun Mar 11, 2018 3:23 am

Re: STK500 error when flashing Marlin

Post: # 744Post zero2005
Mon Mar 12, 2018 10:58 am

Just for follow up, and for the sake of anyone else out there who has this error. hopefully this thread is google searchable.

I ordered a USBASP dongle and after much fiddling around because the dongle I bought came with a horrible 10 to 6 pin adapter that blocks the outer side pins, as opposed to just giving a 6-pin socket adapter where I had to use pin headers to extend the pins then touch them off while simultaneously pressing "burn bootloader" in arduino IDE. I did manage to get the bootloader fixed. note to self to buy a large pack of various style jumper wires.

I'm not sure if anyone else out there has bought an Anet "v1.5" board lately, but I'm wondering if Anet has either made changes to the firmware/bootloader, or if they are somehow getting corrupted another way. I've ran into a few other users out there who are experiencing this problem with newer v1.5 Anet boards.

So, if you have this error, and you are sure that the com port is properly selected, your drivers are correct, and you have the correct "anet v1.0" board selected in the Arduino IDE; if you keep getting STK500 errors, its likely your bootloader is corrupted or otherwise somehow blocking the firmware and you need to reflash the bootloader. I went the USBASP route, though if you have another Arduino already, it also might work if you do it with as an Arduino ISP. -- just make sure the connections are right. there's plenty of vids out there on youtube about how to program the bootloader.

Post Reply