PID Auto Tuning in Marlin

Adding Go Faster Stripes to your 3D Printer
ModMike
Posts: 26
Joined: Thu Feb 08, 2018 3:07 pm

Re: PID Auto Tuning in Marlin

Post: # 555Post ModMike
Tue Feb 20, 2018 3:10 am

I got crazy values when I ran my bed PID:

Kp: 644.76
KI: 117.46
Kp: 884.78

Can you share your values with me to compare?

I have an A2 aluminum bed.



jrvide
Posts: 2
Joined: Wed Feb 28, 2018 9:34 am

Re: PID Auto Tuning in Marlin

Post: # 601Post jrvide
Wed Feb 28, 2018 3:41 pm

Hi,

I've done the PID tunning for the hotend and worked fine, but when I try to do the same for the hotbed I have na error:

> M303 E-1 S60 C8
< PID Autotune start
< Error:Heating failed, system stopped! Heater_ID: bed
< Error:Printer halted. kill() called!


Does somebody know what could be the problem?

ModMike
Posts: 26
Joined: Thu Feb 08, 2018 3:07 pm

Re: PID Auto Tuning in Marlin

Post: # 621Post ModMike
Thu Mar 01, 2018 5:40 pm

When I ran the bed autotune I got a similar error.

This is caused by a value greater than 127 in the WATCH_BED_TEMP_PERIOD. Mine was at 140 so I lowered it to 120 and everything worked fine.

Apparently this issue will be fixed in the next release of Marlin.

Also make sure you specified the right thermistor in Marlin.

jrvide
Posts: 2
Joined: Wed Feb 28, 2018 9:34 am

Re: PID Auto Tuning in Marlin

Post: # 669Post jrvide
Sat Mar 03, 2018 1:29 pm

Hi,

It worked. My value was at 180. I've also changed to 120.
The Autotune give the following values (Anet A8 - Aluminium Bed):

Kp - 414.71
Ki - 58.86
Kd - 730.46

Are these normal values?

ModMike
Posts: 26
Joined: Thu Feb 08, 2018 3:07 pm

Re: PID Auto Tuning in Marlin

Post: # 686Post ModMike
Sat Mar 03, 2018 3:16 pm

Looks similar to mine. Glad to hear it worked.

Cheers!

Post Reply